{"answers":{"affected":"3 open source packages ship an affected version, including fastapi-sso.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14546 exists.","fix":"Upgrade fastapi-sso to 0.19.0 or later.","what":"CVE-2025-14546 is a medium-severity vulnerability in fastapi-sso, published on 19 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-14546 and fix it if it is affected.\n\nWhat it is: CVE-2025-14546 is a medium-severity vulnerability in fastapi-sso, published on 19 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14546 exists.\n\nAffected packages and fixed versions:\n- fastapi-sso (PyPI): affected all versions; fixed in 0.19.0\n- fastapi-sso (PyPI): affected all versions; fixed in 0.19.0\n- fastapi-sso (PyPI): affected all versions; fixed in 0.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14546/ (Markdown: https://insights.sbomify.com/CVE-2025-14546/index.md)","id":"CVE-2025-14546","markdown":"https://insights.sbomify.com/CVE-2025-14546/index.md","name":"CVE-2025-14546","record":{"aliases":["GHSA-hp6r-r9vc-q8wx","MINI-2g5v-3f94-vr86","PYSEC-2026-1362"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Python SSO library","requires_auth":"low_privilege","summary":"Attackers can link their account to a victim's internal account via CSRF due to missing OAuth state validation in fastapi-sso.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Versions of the package fastapi-sso before 0.19.0 are vulnerable to Cross-site Request Forgery (CSRF) due to the improper validation of the OAuth state parameter during the authentication callback. While the get_login_url method allows for state generation, it does not persist the state or bind it to the user's session. Consequently, the verify_and_process method accepts the state received in the query parameters without verifying it against a trusted local value. This allows a remote attacker to trick a victim into visiting a malicious callback URL, which can result in the attacker's account being linked to the victim's internal account.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FastAPI SSP is vulnerable to Cross-site Request Forgery (CSRF) through improper OAuth parameter validation","id":"CVE-2025-14546","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"ECJ-PAKE Integer Underflow Vulnerability in Silicon Labs PSA Crypto and SE Manager APIs","id":"CVE-2025-14547"},"packages":[{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"fastapi-sso","purl":null,"source":"GHSA-hp6r-r9vc-q8wx"},{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"fastapi-sso","purl":"pkg:pypi/fastapi-sso","source":"GHSA-hp6r-r9vc-q8wx"},{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0"],"last_affected":[],"package":"fastapi-sso","purl":"pkg:pypi/fastapi-sso","source":"PYSEC-2026-1362"}],"prev":{"headline":"YML for Yandex Market \u003c 5.0.26 - Shop Manager+ RCE via Feed Generation","id":"CVE-2025-14545"},"products":["fastapi-sso"],"published":"2025-12-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-19","vendors":["n/a"]},"summary":"Attackers can link their account to a victim's internal account via CSRF due to missing OAuth state validation in fastapi-sso.","url":"https://insights.sbomify.com/CVE-2025-14546/"}