# CVE-2025-14546: FastAPI SSP is vulnerable to Cross-site Request Forgery (CSRF) through improper OAuth parameter validation

> Attackers can link their account to a victim's internal account via CSRF due to missing OAuth state validation in fastapi-sso.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Dec 2025
- **Updated:** 19 Dec 2025
- **Also known as:** GHSA-hp6r-r9vc-q8wx, MINI-2g5v-3f94-vr86, PYSEC-2026-1362

## What is CVE-2025-14546?

CVE-2025-14546 is a medium-severity vulnerability in fastapi-sso, published on 19 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Versions of the package fastapi-sso before 0.19.0 are vulnerable to Cross-site Request Forgery (CSRF) due to the improper validation of the OAuth state parameter during the authentication callback. While the get_login_url method allows for state generation, it does not persist the state or bind it to the user's session. Consequently, the verify_and_process method accepts the state received in the query parameters without verifying it against a trusted local value. This allows a remote attacker to trick a victim into visiting a malicious callback URL, which can result in the attacker's account being linked to the victim's internal account.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-14546?

3 open source packages ship an affected version, including fastapi-sso.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastapi-sso` | PyPI | All versions | 0.19.0 |
| `fastapi-sso` | PyPI | All versions | 0.19.0 |
| `fastapi-sso` | PyPI | All versions | 0.19.0 |

## How do I fix CVE-2025-14546?

Upgrade fastapi-sso to 0.19.0 or later.

## Is CVE-2025-14546 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14546 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14546 and fix it if it is affected.

What it is: CVE-2025-14546 is a medium-severity vulnerability in fastapi-sso, published on 19 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14546 exists.

Affected packages and fixed versions:
- fastapi-sso (PyPI): affected all versions; fixed in 0.19.0
- fastapi-sso (PyPI): affected all versions; fixed in 0.19.0
- fastapi-sso (PyPI): affected all versions; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14546/ (Markdown: https://insights.sbomify.com/CVE-2025-14546/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14546
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14546
- OSV: https://osv.dev/vulnerability/CVE-2025-14546

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14546/
Summaries are generated and may contain mistakes; the official description above is the record.
