CVE-2025-14550 Potential denial-of-service vulnerability via repeated headers when using ASGI
Remote attackers can cause denial of service in Django ASGI applications by sending requests with multiple duplicate headers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-14550?
CVE-2025-14550 is a high-severity denial of service vulnerability in Djangoproject Django, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28. `ASGIRequest` allows a remote attacker to cause a potential denial-of-service via a crafted request with multiple duplicate headers. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Jiyong Yang for reporting this issue.
Weakness: CWE-407
Which versions are affected by CVE-2025-14550?
8 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 4.2.28, 5.2.11, 6.0.2 |
django PyPI | From 4.2 | 4.2.28, 5.2.11, 6.0.2 |
django PyPI | From 4.2a1 | 4.2.28 |
django PyPI | From 5.2a1 | 5.2.11 |
django PyPI | From 6.0a1 | 6.0.2 |
Django PyPI | From 4.2a1 | 4.2.28 |
2 more packages
Django PyPI | From 5.2a1 | 5.2.11 |
Django PyPI | From 6.0a1 | 6.0.2 |
Linux distribution packages (1)
python-asgiref openSUSE:Tumbleweed | All versions | 3.11.1-1.1 |
Products include Djangoproject Django.
How do I fix CVE-2025-14550?
Upgrade django to a fixed version for your release line: 4.2.28, 5.2.11 or 6.0.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-14550 being exploited?
There is no known exploitation of CVE-2025-14550 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2025-14550, DEBIAN-CVE-2025-14550, ECHO-5865-ae76-0fca, GHSA-33mw-q7rj-mjwj, MINI-x9x3-v97f-fxhp, PYSEC-2026-43 and 1 more.