CVE-2025-14562 Incorrect Authorization in GitLab

Low 3.1 Published Updated

Authenticated developers can commit changes to projects after removal due to improper authorization checks in merge request settings.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-14562?

CVE-2025-14562 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.6 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to commit changes to a project after being removed as a member, due to improper authorization checks on merge request collaboration settings.

Weakness: CWE-863

Which versions are affected by CVE-2025-14562?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.6.019.0.5, 19.1.3, 19.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-14562?

Upgrade gitlab to a fixed version for your release line: 19.0.5, 19.1.3 or 19.2.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-14562 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14562 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-14562, GHSA-45h8-qrqh-xr5v, MINI-3655-v5rv-w93r, MINI-pwvh-36pw-c87f.

Is CVE-2025-14562 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free