# CVE-2025-14562: Incorrect Authorization in GitLab

> Authenticated developers can commit changes to projects after removal due to improper authorization checks in merge request settings.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** BIT-gitlab-2025-14562, GHSA-45h8-qrqh-xr5v, MINI-3655-v5rv-w93r, MINI-pwvh-36pw-c87f

## What is CVE-2025-14562?

CVE-2025-14562 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.6 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to commit changes to a project after being removed as a member, due to improper authorization checks on merge request collaboration settings.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-14562?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 10.6.0 | 19.0.5, 19.1.3, 19.2.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-14562?

Upgrade gitlab to a fixed version for your release line: 19.0.5, 19.1.3 or 19.2.1.

## Is CVE-2025-14562 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14562 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14562 and fix it if it is affected.

What it is: CVE-2025-14562 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14562 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 10.6.0; fixed in 19.0.5, 19.1.3, 19.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14562/ (Markdown: https://insights.sbomify.com/CVE-2025-14562/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14562
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14562
- OSV: https://osv.dev/vulnerability/CVE-2025-14562

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14562/
Summaries are generated and may contain mistakes; the official description above is the record.
