# CVE-2025-14573: Team Admin Bypass of Invite Permissions via allow_open_invite Field

> Team administrators can bypass invite permission restrictions to add unauthorized users to teams via API requests.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2026
- **Updated:** 17 Feb 2026
- **Also known as:** GHSA-cgjg-p2m2-qm4p, GO-2026-4523

## What is CVE-2025-14573?

CVE-2025-14573 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 10.11.x <= 10.11.9 fail to enforce invite permissions when updating team settings, which allows team administrators without proper permissions to bypass restrictions and add users to their team via API requests. Mattermost Advisory ID: MMSA-2025-00561

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-14573?

17 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20251215190648-6404ab29acc0 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 5.3.2-0.20251215190648-6404ab29acc0 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.1.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.1.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.1.0+incompatible | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.2.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.2.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 11.2.0+incompatible | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251215190648-6404ab29acc0 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251215190648-6404ab29acc0 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251215190648-6404ab29acc0 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-14573?

Upgrade github.com/mattermost/mattermost-server to 5.3.2-0.20251215190648-6404ab29acc0 or later.

## Is CVE-2025-14573 being exploited?

There is no known exploitation of CVE-2025-14573 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14573 and fix it if it is affected.

What it is: CVE-2025-14573 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-14573 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20251215190648-6404ab29acc0
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 5.3.2-0.20251215190648-6404ab29acc0
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.1.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.1.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.1.0+incompatible; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.2.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.2.0; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 11.2.0+incompatible; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14573/ (Markdown: https://insights.sbomify.com/CVE-2025-14573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14573
- OSV: https://osv.dev/vulnerability/CVE-2025-14573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14573/
Summaries are generated and may contain mistakes; the official description above is the record.
