CVE-2025-14592 Missing Authorization in GitLab

Low 3.7 Published Updated

Authenticated users can perform unauthorized operations via GraphQL mutations in GitLab, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-14592?

CVE-2025-14592 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.6 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions could have allowed an authenticated user to perform unauthorized operations by submitting GraphQL mutations through the GLQL API endpoint.

Weakness: CWE-862

Which versions are affected by CVE-2025-14592?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.6.018.6.6, 18.7.4, 18.8.4

Products include Gitlab Gitlab.

How do I fix CVE-2025-14592?

Upgrade gitlab to a fixed version for your release line: 18.6.6, 18.7.4 or 18.8.4.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-14592 being exploited?

There is no known exploitation of CVE-2025-14592 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-14592, GHSA-xfh9-f34g-8fm7, UBUNTU-CVE-2025-14592.

Is CVE-2025-14592 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free