CVE-2025-14594 Authorization Bypass Through User-Controlled Key in GitLab

Low 3.5 Published Updated

Authenticated users can bypass authorization checks to view sensitive pipeline values via the API in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-14594?

CVE-2025-14594 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.11 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions could have allowed an authenticated user to view certain pipeline values by querying the API.

Weakness: CWE-639

Which versions are affected by CVE-2025-14594?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.11.018.6.6, 18.7.4, 18.8.4

Products include Gitlab Gitlab.

How do I fix CVE-2025-14594?

Upgrade gitlab to a fixed version for your release line: 18.6.6, 18.7.4 or 18.8.4.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-14594 being exploited?

There is no known exploitation of CVE-2025-14594 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-14594, GHSA-3c27-7487-m6fw, UBUNTU-CVE-2025-14594.

Is CVE-2025-14594 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free