# CVE-2025-14660: DecoCMS Mesh Workspace Domain api.ts createTool access control

> Remote attackers can bypass access controls in the Workspace Domain Handler to perform unauthorized actions, requiring an upgrade to fix.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Dec 2025
- **Updated:** 15 Dec 2025
- **Also known as:** GHSA-cp89-j668-cmf6

## What is CVE-2025-14660?

CVE-2025-14660 is a medium-severity missing authorization vulnerability in DecoCMS Mesh, published on 14 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw has been found in DecoCMS Mesh up to 1.0.0-alpha.31. Affected by this vulnerability is the function createTool of the file packages/sdk/src/mcp/teams/api.ts of the component Workspace Domain Handler. This manipulation of the argument domain causes improper access controls. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. The exploit has been published and may be used. Upgrading to version 1.0.0-alpha.32 addresses this issue. Patch name: 5f7315e05852faf3a9c177c0a34f9ea9b0371d3d. It is recommended to upgrade the affected component.

Weakness: CWE-284 (Improper Access Control), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-14660?


## How do I fix CVE-2025-14660?

No fix has been published for CVE-2025-14660 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-14660 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14660 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14660 and fix it if it is affected.

What it is: CVE-2025-14660 is a medium-severity missing authorization vulnerability in DecoCMS Mesh, published on 14 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14660 exists.

Affected product: DecoCMS Mesh. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14660/ (Markdown: https://insights.sbomify.com/CVE-2025-14660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14660
- OSV: https://osv.dev/vulnerability/CVE-2025-14660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14660/
Summaries are generated and may contain mistakes; the official description above is the record.
