{"answers":{"affected":"2 open source packages ship an affected version, including tarteaucitronjs.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1467 exists.","fix":"Upgrade tarteaucitronjs to 1.17.0 or later.","what":"CVE-2025-1467 is a medium-severity cross-site scripting vulnerability in tarteaucitronjs, published on 23 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-1467 and fix it if it is affected.\n\nWhat it is: CVE-2025-1467 is a medium-severity cross-site scripting vulnerability in tarteaucitronjs, published on 23 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1467 exists.\n\nAffected packages and fixed versions:\n- tarteaucitronjs (npm): affected all versions; fixed in 1.17.0\n- tarteaucitronjs (npm): affected all versions; fixed in 1.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1467/ (Markdown: https://insights.sbomify.com/CVE-2025-1467/index.md)","id":"CVE-2025-1467","markdown":"https://insights.sbomify.com/CVE-2025-1467/index.md","name":"CVE-2025-1467","record":{"aliases":["GHSA-8wp9-x25p-8794"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript cookie consent library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the victim's browser via the getElemWidth and getElemHeight functions in the tarteaucitronjs library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Versions of the package tarteaucitronjs before 1.17.0 are vulnerable to Cross-site Scripting (XSS) via the getElemWidth() and getElemHeight(). This is related to [SNYK-JS-TARTEAUCITRONJS-8366541](https://security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8366541)","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"tarteaucitron Cross-site Scripting (XSS)","id":"CVE-2025-1467","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"CODESYS Control V3 - OPC UA Server Authentication bypass","id":"CVE-2025-1468"},"packages":[{"ecosystem":"npm","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"tarteaucitronjs","purl":null,"source":"GHSA-8wp9-x25p-8794"},{"ecosystem":"npm","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"tarteaucitronjs","purl":"pkg:npm/tarteaucitronjs","source":"GHSA-8wp9-x25p-8794"}],"prev":{"headline":"lmxcms Maintenance db.inc.php code injection","id":"CVE-2025-1465"},"products":["tarteaucitronjs"],"published":"2025-02-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-24","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts in the victim's browser via the getElemWidth and getElemHeight functions in the tarteaucitronjs library.","url":"https://insights.sbomify.com/CVE-2025-1467/"}