# CVE-2025-1467: tarteaucitron Cross-site Scripting (XSS)

> An attacker can execute arbitrary scripts in the victim's browser via the getElemWidth and getElemHeight functions in the tarteaucitronjs library.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Feb 2025
- **Updated:** 24 Feb 2025
- **Also known as:** GHSA-8wp9-x25p-8794

## What is CVE-2025-1467?

CVE-2025-1467 is a medium-severity cross-site scripting vulnerability in tarteaucitronjs, published on 23 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package tarteaucitronjs before 1.17.0 are vulnerable to Cross-site Scripting (XSS) via the getElemWidth() and getElemHeight(). This is related to [SNYK-JS-TARTEAUCITRONJS-8366541](https://security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8366541)

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-1467?

2 open source packages ship an affected version, including tarteaucitronjs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tarteaucitronjs` | npm | All versions | 1.17.0 |
| `tarteaucitronjs` | npm | All versions | 1.17.0 |

## How do I fix CVE-2025-1467?

Upgrade tarteaucitronjs to 1.17.0 or later.

## Is CVE-2025-1467 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1467 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1467 and fix it if it is affected.

What it is: CVE-2025-1467 is a medium-severity cross-site scripting vulnerability in tarteaucitronjs, published on 23 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1467 exists.

Affected packages and fixed versions:
- tarteaucitronjs (npm): affected all versions; fixed in 1.17.0
- tarteaucitronjs (npm): affected all versions; fixed in 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1467/ (Markdown: https://insights.sbomify.com/CVE-2025-1467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1467
- OSV: https://osv.dev/vulnerability/CVE-2025-1467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1467/
Summaries are generated and may contain mistakes; the official description above is the record.
