{"answers":{"affected":"2 open source packages ship an affected version, including com.aizuda:snail-job.","exploited":"There is no known exploitation of CVE-2025-14674 in the wild and no public exploit code.","fix":"Upgrade com.aizuda:snail-job to 1.7.0-beta1 or later.","what":"CVE-2025-14674 is a medium-severity code injection vulnerability in aizuda snail-job, published on 14 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-14674 and fix it if it is affected.\n\nWhat it is: CVE-2025-14674 is a medium-severity code injection vulnerability in aizuda snail-job, published on 14 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-14674 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.aizuda:snail-job (Maven): affected all versions; fixed in 1.7.0-beta1\n- com.aizuda:snail-job (Maven): affected all versions; fixed in 1.7.0-beta1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14674/ (Markdown: https://insights.sbomify.com/CVE-2025-14674/index.md)","id":"CVE-2025-14674","markdown":"https://insights.sbomify.com/CVE-2025-14674/index.md","name":"CVE-2025-14674","record":{"aliases":["GHSA-3f8c-8h8v-p54h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java job scheduling library","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code via injection in the QLExpressEngine evaluation function of the snail-job library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-707","name":"Improper Neutralization"}],"description":"A vulnerability was found in aizuda snail-job up to 1.6.0. Affected by this vulnerability is the function QLExpressEngine.doEval of the file snail-job-common/snail-job-common-core/src/main/java/com/aizuda/snailjob/common/core/expression/strategy/QLExpressEngine.java. The manipulation results in injection. The attack can be launched remotely. Upgrading to version 1.7.0-beta1 addresses this issue. The patch is identified as 978f316c38b3d68bb74d2489b5e5f721f6675e86. The affected component should be upgraded.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"aizuda snail-job QLExpressEngine.java QLExpressEngine.doEval injection","id":"CVE-2025-14674","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":7,"next":{"headline":"Meta Box \u003c= 5.11.1 - Authenticated (Contributor+) Arbitrary File Deletion","id":"CVE-2025-14675"},"packages":[{"ecosystem":"Maven","fixed":["1.7.0-beta1"],"introduced":["0"],"last_affected":[],"package":"com.aizuda:snail-job","purl":null,"source":"GHSA-3f8c-8h8v-p54h"},{"ecosystem":"Maven","fixed":["1.7.0-beta1"],"introduced":["0"],"last_affected":[],"package":"com.aizuda:snail-job","purl":"pkg:maven/com.aizuda/snail-job","source":"GHSA-3f8c-8h8v-p54h"}],"prev":{"headline":"gmg137 snap7-rs client.rs as_ct_write heap-based overflow","id":"CVE-2025-14673"},"products":["snail-job"],"published":"2025-12-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-24","vendors":["aizuda"]},"summary":"Remote attackers can execute arbitrary code via injection in the QLExpressEngine evaluation function of the snail-job library.","url":"https://insights.sbomify.com/CVE-2025-14674/"}