# CVE-2025-14674: aizuda snail-job QLExpressEngine.java QLExpressEngine.doEval injection

> Remote attackers can execute arbitrary code via injection in the QLExpressEngine evaluation function of the snail-job library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2025
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-3f8c-8h8v-p54h

## What is CVE-2025-14674?

CVE-2025-14674 is a medium-severity code injection vulnerability in aizuda snail-job, published on 14 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in aizuda snail-job up to 1.6.0. Affected by this vulnerability is the function QLExpressEngine.doEval of the file snail-job-common/snail-job-common-core/src/main/java/com/aizuda/snailjob/common/core/expression/strategy/QLExpressEngine.java. The manipulation results in injection. The attack can be launched remotely. Upgrading to version 1.7.0-beta1 addresses this issue. The patch is identified as 978f316c38b3d68bb74d2489b5e5f721f6675e86. The affected component should be upgraded.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2025-14674?

2 open source packages ship an affected version, including com.aizuda:snail-job.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.aizuda:snail-job` | Maven | All versions | 1.7.0-beta1 |
| `com.aizuda:snail-job` | Maven | All versions | 1.7.0-beta1 |

## How do I fix CVE-2025-14674?

Upgrade com.aizuda:snail-job to 1.7.0-beta1 or later.

## Is CVE-2025-14674 being exploited?

There is no known exploitation of CVE-2025-14674 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14674 and fix it if it is affected.

What it is: CVE-2025-14674 is a medium-severity code injection vulnerability in aizuda snail-job, published on 14 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-14674 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.aizuda:snail-job (Maven): affected all versions; fixed in 1.7.0-beta1
- com.aizuda:snail-job (Maven): affected all versions; fixed in 1.7.0-beta1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14674/ (Markdown: https://insights.sbomify.com/CVE-2025-14674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14674
- OSV: https://osv.dev/vulnerability/CVE-2025-14674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14674/
Summaries are generated and may contain mistakes; the official description above is the record.
