CVE-2025-14675 Meta Box <= 5.11.1 - Authenticated (Contributor+) Arbitrary File Deletion

High 7.2 Published Updated

Authenticated contributors can delete arbitrary files via path traversal, potentially leading to remote code execution.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-14675?

CVE-2025-14675 is a high-severity path traversal vulnerability in metabox Meta Box, published on 7 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

The Meta Box plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'ajax_delete_file' function in all versions up to, and including, 5.11.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).

Weakness: CWE-22

Which versions are affected by CVE-2025-14675?

2 open source packages ship an affected version, including wpmetabox/meta-box.

PackageAffectedFixed in
wpmetabox/meta-box PackagistAll versions5.11.2
wpmetabox/meta-box PackagistAll versions5.11.2

How do I fix CVE-2025-14675?

Upgrade wpmetabox/meta-box to 5.11.2 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-14675 being exploited?

There is no known exploitation of CVE-2025-14675 in the wild and no public exploit code.

Sources

Also known as GHSA-m4q3-832v-44j6.

Is CVE-2025-14675 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free