{"answers":{"affected":"2 open source packages ship an affected version, including wpmetabox/meta-box.","exploited":"There is no known exploitation of CVE-2025-14675 in the wild and no public exploit code.","fix":"Upgrade wpmetabox/meta-box to 5.11.2 or later.","what":"CVE-2025-14675 is a high-severity path traversal vulnerability in metabox Meta Box, published on 7 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-14675 and fix it if it is affected.\n\nWhat it is: CVE-2025-14675 is a high-severity path traversal vulnerability in metabox Meta Box, published on 7 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-14675 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wpmetabox/meta-box (Packagist): affected all versions; fixed in 5.11.2\n- wpmetabox/meta-box (Packagist): affected all versions; fixed in 5.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-14675/ (Markdown: https://insights.sbomify.com/CVE-2025-14675/index.md)","id":"CVE-2025-14675","markdown":"https://insights.sbomify.com/CVE-2025-14675/index.md","name":"CVE-2025-14675","record":{"aliases":["GHSA-m4q3-832v-44j6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Authenticated contributors can delete arbitrary files via path traversal, potentially leading to remote code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The Meta Box plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'ajax_delete_file' function in all versions up to, and including, 5.11.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Meta Box \u003c= 5.11.1 - Authenticated (Contributor+) Arbitrary File Deletion","id":"CVE-2025-14675","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"IBM Maximo Application Suite - Monitor Component uses Log Forging which is vulnerable to .","id":"CVE-2025-14684"},"packages":[{"ecosystem":"Packagist","fixed":["5.11.2"],"introduced":["0"],"last_affected":[],"package":"wpmetabox/meta-box","purl":null,"source":"GHSA-m4q3-832v-44j6"},{"ecosystem":"Packagist","fixed":["5.11.2"],"introduced":["0"],"last_affected":[],"package":"wpmetabox/meta-box","purl":"pkg:composer/wpmetabox/meta-box","source":"GHSA-m4q3-832v-44j6"}],"prev":{"headline":"aizuda snail-job QLExpressEngine.java QLExpressEngine.doEval injection","id":"CVE-2025-14674"},"products":["Meta Box"],"published":"2026-03-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["metabox"]},"summary":"Authenticated contributors can delete arbitrary files via path traversal, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2025-14675/"}