# CVE-2025-14691: Mayan EDMS authentication cross site scripting

> Remote attackers can execute arbitrary scripts in Mayan EDMS via cross-site scripting in the authentication module, potentially compromising user sessions.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Dec 2025
- **Updated:** 15 Dec 2025
- **Also known as:** GHSA-774q-r975-vqwp, PYSEC-2025-134

## What is CVE-2025-14691?

CVE-2025-14691 is a medium-severity cross-site scripting vulnerability in Mayan EDMS, published on 14 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. You should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-14691?

11 open source packages ship an affected version, including mayan-edms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mayan-edms` | PyPI | All versions | 4.10.2 |
| `mayan-edms` | PyPI | All versions | 4.6.12 |
| `mayan-edms` | PyPI | All versions | 4.6.12 |
| `mayan-edms` | PyPI | From 4.10.0 | 4.10.2 |
| `mayan-edms` | PyPI | From 4.10.0 | 4.10.2 |
| `mayan-edms` | PyPI | From 4.7.0 | 4.7.8 |
| `mayan-edms` | PyPI | From 4.7.0 | 4.7.8 |
| `mayan-edms` | PyPI | From 4.8.0 | 4.8.10 |
| `mayan-edms` | PyPI | From 4.8.0 | 4.8.10 |
| `mayan-edms` | PyPI | From 4.9.0 | 4.9.7 |
| `mayan-edms` | PyPI | From 4.9.0 | 4.9.7 |

Products: Mayan-Edms Mayan Edms.

## How do I fix CVE-2025-14691?

Upgrade mayan-edms to a fixed version for your release line: 4.10.2, 4.6.12, 4.7.8 or 4.8.10.

## Is CVE-2025-14691 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14691 exists.

## Other vulnerabilities in Mayan EDMS

- [CVE-2018-16405](https://insights.sbomify.com/CVE-2018-16405/): mayan-edms Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2018-16406](https://insights.sbomify.com/CVE-2018-16406/): Moderate severity vulnerability that affects mayan-edms (medium 6.1)
- [CVE-2018-16407](https://insights.sbomify.com/CVE-2018-16407/): Moderate severity vulnerability that affects mayan-edms (medium 6.1)
- [CVE-2022-47419](https://insights.sbomify.com/CVE-2022-47419/): Mayan EDMS Tag XSS (medium 5.4)
- [CVE-2025-14692](https://insights.sbomify.com/CVE-2025-14692/): Mayan EDMS authentication redirect (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14691 and fix it if it is affected.

What it is: CVE-2025-14691 is a medium-severity cross-site scripting vulnerability in Mayan EDMS, published on 14 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-14691 exists.

Affected packages and fixed versions:
- mayan-edms (PyPI): affected all versions; fixed in 4.10.2
- mayan-edms (PyPI): affected all versions; fixed in 4.6.12
- mayan-edms (PyPI): affected all versions; fixed in 4.6.12
- mayan-edms (PyPI): affected from 4.10.0; fixed in 4.10.2
- mayan-edms (PyPI): affected from 4.10.0; fixed in 4.10.2
- mayan-edms (PyPI): affected from 4.7.0; fixed in 4.7.8
- mayan-edms (PyPI): affected from 4.7.0; fixed in 4.7.8
- mayan-edms (PyPI): affected from 4.8.0; fixed in 4.8.10
- mayan-edms (PyPI): affected from 4.8.0; fixed in 4.8.10
- mayan-edms (PyPI): affected from 4.9.0; fixed in 4.9.7
- mayan-edms (PyPI): affected from 4.9.0; fixed in 4.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14691/ (Markdown: https://insights.sbomify.com/CVE-2025-14691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14691
- OSV: https://osv.dev/vulnerability/CVE-2025-14691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14691/
Summaries are generated and may contain mistakes; the official description above is the record.
