CVE-2025-1472 Unauthorized View Access to Site Statistics and Team Statistics
Attackers with Viewer role can bypass reporting restrictions to view sensitive team and site statistics in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-1472?
CVE-2025-1472 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 9.11.x <= 9.11.8 fail to properly perform authorization of the Viewer role which allows an attacker with the Viewer role configured with No Access to Reporting to still view team and site statistics.
Weakness: CWE-863
Which versions are affected by CVE-2025-1472?
8 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.9 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.9 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.9+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
2 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.9 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.9 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-1472?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 9.11.9 or 9.11.9+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-1472 being exploited?
There is no known exploitation of CVE-2025-1472 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-fqrq-xmxj-v47x, GO-2025-3534.