CVE-2025-1474 Weak Password Requirements in mlflow/mlflow

Low 3.8 Published Updated

Admins can create user accounts without passwords, allowing unauthorized access to those accounts.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-1474?

CVE-2025-1474 is a low-severity vulnerability in Lfprojects Mlflow, published on 20 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In mlflow/mlflow version 2.18, an admin is able to create a new user account without setting a password. This vulnerability could lead to security risks, as accounts without passwords may be susceptible to unauthorized access. Additionally, this issue violates best practices for secure user account management. The issue is fixed in version 2.19.0.

Weakness: CWE-521

Which versions are affected by CVE-2025-1474?

4 open source packages ship an affected version, including mlflow. It affects 1 product.

PackageAffectedFixed in
mlflow BitnamiAll versions2.19.0
mlflow PyPIAll versions2.19.0
mlflow PyPIAll versions2.19.0
mlflow PyPIAll versions2.19.0

Products include Lfprojects Mlflow.

How do I fix CVE-2025-1474?

Upgrade mlflow to 2.19.0 or later.

Is CVE-2025-1474 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1474 exists.

All Lfprojects Mlflow vulnerabilities

Sources

Also known as BIT-mlflow-2025-1474, GHSA-4rj2-9gcx-5qhx, PYSEC-2025-17.

Is CVE-2025-1474 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free