# CVE-2025-1474: Weak Password Requirements in mlflow/mlflow

> Admins can create user accounts without passwords, allowing unauthorized access to those accounts.

- **Severity:** Low 3.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** BIT-mlflow-2025-1474, GHSA-4rj2-9gcx-5qhx, PYSEC-2025-17

## What is CVE-2025-1474?

CVE-2025-1474 is a low-severity vulnerability in Lfprojects Mlflow, published on 20 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In mlflow/mlflow version 2.18, an admin is able to create a new user account without setting a password. This vulnerability could lead to security risks, as accounts without passwords may be susceptible to unauthorized access. Additionally, this issue violates best practices for secure user account management. The issue is fixed in version 2.19.0.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2025-1474?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 2.19.0 |
| `mlflow` | PyPI | All versions | 2.19.0 |
| `mlflow` | PyPI | All versions | 2.19.0 |
| `mlflow` | PyPI | All versions | 2.19.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2025-1474?

Upgrade mlflow to 2.19.0 or later.

## Is CVE-2025-1474 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1474 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1474 and fix it if it is affected.

What it is: CVE-2025-1474 is a low-severity vulnerability in Lfprojects Mlflow, published on 20 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1474 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 2.19.0
- mlflow (PyPI): affected all versions; fixed in 2.19.0
- mlflow (PyPI): affected all versions; fixed in 2.19.0
- mlflow (PyPI): affected all versions; fixed in 2.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1474/ (Markdown: https://insights.sbomify.com/CVE-2025-1474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1474
- OSV: https://osv.dev/vulnerability/CVE-2025-1474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1474/
Summaries are generated and may contain mistakes; the official description above is the record.
