CVE-2025-1477 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

Unauthenticated attackers can cause denial of service in GitLab by sending crafted payloads to integration API endpoints.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-1477?

CVE-2025-1477 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 8.14 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed an unauthenticated user to create a denial of service condition by sending specially crafted payloads to specific integration API endpoints.

Weakness: CWE-770

Which versions are affected by CVE-2025-1477?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.14.018.0.6, 18.1.4, 18.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-1477?

Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-1477 being exploited?

There is no known exploitation of CVE-2025-1477 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-1477, GHSA-4vc6-9m66-j82c, MINI-24qc-hrj7-7p7c, MINI-763g-c453-fq38, MINI-98v3-wc34-9vfr, UBUNTU-CVE-2025-1477.

Is CVE-2025-1477 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free