CVE-2025-14822 DoS from quadratic complexity in model.ParseHashtags
An authenticated attacker can cause denial of service by sending a post with many tokens, exhausting CPU resources due to quadratic complexity in hashtag parsing.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-14822?
CVE-2025-14822 is a low-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.11.x <= 10.11.8 fail to validate input size before processing hashtags which allows an authenticated attacker to exhaust CPU resources via a single HTTP request containing a post with thousands space-separated tokens
Which versions are affected by CVE-2025-14822?
5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.9 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.9 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.9+incompatible, 11.2.0+incompatible |
github.com/mattermost/mattermost-server Go | From 11.0.0 | 11.2.0 |
github.com/mattermost/mattermost-server Go | From 11.0.0 | 11.2.0 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-14822?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.9, 10.11.9+incompatible, 11.2.0+incompatible or 11.2.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-14822 being exploited?
There is no known exploitation of CVE-2025-14822 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-9r42-rhw3-2222, GO-2026-4325.