# CVE-2025-14822: DoS from quadratic complexity in model.ParseHashtags

> An authenticated attacker can cause denial of service by sending a post with many tokens, exhausting CPU resources due to quadratic complexity in hashtag parsing.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2026
- **Updated:** 16 Jan 2026
- **Also known as:** GHSA-9r42-rhw3-2222, GO-2026-4325

## What is CVE-2025-14822?

CVE-2025-14822 is a low-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.11.x <= 10.11.8 fail to validate input size before processing hashtags which allows an authenticated attacker to exhaust CPU resources via a single HTTP request containing a post with thousands space-separated tokens

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2025-14822?

5 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.9 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.9 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.9+incompatible, 11.2.0+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.0.0 | 11.2.0 |
| `github.com/mattermost/mattermost-server` | Go | From 11.0.0 | 11.2.0 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-14822?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.9, 10.11.9+incompatible, 11.2.0+incompatible or 11.2.0.

## Is CVE-2025-14822 being exploited?

There is no known exploitation of CVE-2025-14822 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14822 and fix it if it is affected.

What it is: CVE-2025-14822 is a low-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-14822 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.9
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.9
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.9+incompatible, 11.2.0+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.0.0; fixed in 11.2.0
- github.com/mattermost/mattermost-server (Go): affected from 11.0.0; fixed in 11.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14822/ (Markdown: https://insights.sbomify.com/CVE-2025-14822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14822
- OSV: https://osv.dev/vulnerability/CVE-2025-14822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14822/
Summaries are generated and may contain mistakes; the official description above is the record.
