CVE-2025-14847 MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency

Exploited in the wild High 8.7 Published Updated

An unauthenticated attacker can read uninitialized heap memory via mismatched length fields in Zlib compressed protocol headers.

Exploited in the wild
Since 29 Dec 2025
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-14847?

CVE-2025-14847 is a high-severity vulnerability in Mongodb Mongodb, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Mismatched length fields in Zlib compressed protocol headers may allow a read of uninitialized heap memory by an unauthenticated client. This issue affects all MongoDB Server v7.0 prior to 7.0.28 versions, MongoDB Server v8.0 versions prior to 8.0.17, MongoDB Server v8.2 versions prior to 8.2.3, MongoDB Server v6.0 versions prior to 6.0.27, MongoDB Server v5.0 versions prior to 5.0.32, MongoDB Server v4.4 versions prior to 4.4.30, MongoDB Server v4.2 versions greater than or equal to 4.2.0, MongoDB Server v4.0 versions greater than or equal to 4.0.0, and MongoDB Server v3.6 versions greater than or equal to 3.6.0.

Weakness: CWE-130

Which versions are affected by CVE-2025-14847?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 4.4.04.4.30, 5.0.32, 6.0.27, 7.0.28, 8.0.17, 8.2.3

Products include Mongodb Mongodb.

How do I fix CVE-2025-14847?

Upgrade mongodb to a fixed version for your release line: 4.4.30, 5.0.32, 6.0.27 or 7.0.28. US federal agencies must fix it by 19 Jan 2026.

Is CVE-2025-14847 being exploited?

Yes. Attackers have exploited CVE-2025-14847 in the wild since at least 29 Dec 2025.

Public exploit code: 1 Metasploit module, 1 Nuclei template and 41 proofs of concept on GitHub.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-14847, CLEANSTART-2026-KV44579, CLSA-2026-1773757893, CLSA-2026-1773768694, GHSA-4742-mr57-2r9j, MINI-q86m-mrfj-hqf8 and 3 more.

Is CVE-2025-14847 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free