# CVE-2025-14847: MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency

> An unauthenticated attacker can read uninitialized heap memory via mismatched length fields in Zlib compressed protocol headers.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Yes, since 29 Dec 2025 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-mongodb-2025-14847, CLEANSTART-2026-KV44579, CLSA-2026-1773757893, CLSA-2026-1773768694, GHSA-4742-mr57-2r9j, MINI-q86m-mrfj-hqf8, MINI-rh5w-986w-8qhv, UBUNTU-CVE-2025-14847, USN-8160-1

## What is CVE-2025-14847?

CVE-2025-14847 is a high-severity vulnerability in Mongodb Mongodb, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mismatched length fields in Zlib compressed protocol headers may allow a read of uninitialized heap memory by an unauthenticated client. This issue affects all MongoDB Server v7.0 prior to 7.0.28 versions, MongoDB Server v8.0 versions prior to 8.0.17, MongoDB Server v8.2 versions prior to 8.2.3, MongoDB Server v6.0 versions prior to 6.0.27, MongoDB Server v5.0 versions prior to 5.0.32, MongoDB Server v4.4 versions prior to 4.4.30, MongoDB Server v4.2 versions greater than or equal to 4.2.0, MongoDB Server v4.0 versions greater than or equal to 4.0.0, and MongoDB Server v3.6 versions greater than or equal to 3.6.0.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2025-14847?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 4.4.0 | 4.4.30, 5.0.32, 6.0.27, 7.0.28, 8.0.17, 8.2.3 |

Products: Mongodb Mongodb.

## How do I fix CVE-2025-14847?

Upgrade mongodb to a fixed version for your release line: 4.4.30, 5.0.32, 6.0.27 or 7.0.28. US federal agencies must fix it by 19 Jan 2026.

## Is CVE-2025-14847 being exploited?

Yes. Attackers have exploited CVE-2025-14847 in the wild since at least 29 Dec 2025.

Public exploit code:

- MongoDB CVE-2025-14847 Heap Memory Leak Scanner | OP_COMPRESSED zlib Vulnerability | Bug Bounty & Red Team Tool (github_poc): https://github.com/Black1hp/mongobleed-scanner
- a critical memory disclosure vulnerability in MongoDB's zlib compression handling. This tool allows security researchers to extract sensitive data from vulnerable MongoDB instances. (github_poc): https://github.com/cybertechajju/CVE-2025-14847_Expolit
- poc for CVE-2025-14847 (github_poc): https://github.com/ProbiusOfficial/CVE-2025-14847
-  MongoDB 内存泄露漏洞 (CVE-2025-14847) 检测工具 (github_poc): https://github.com/onewinner/CVE-2025-14847
- Exploit lab, docker and code scanner for mongobleed Vulnerability CVE-2025-14847 plus Phoenix Security Sync tools (github_poc): https://github.com/Security-Phoenix-demo/mongobleed-exploit-CVE-2025-14847
- Academic proof-of-concept demonstrating CVE-2025-14847 for authorized security research. (github_poc): https://github.com/codeb0ssx/CVE-2025-14847-PoC

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)
- [CVE-2024-1351](https://insights.sbomify.com/CVE-2024-1351/): MongoDB Server may allow successful untrusted connection (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14847 and fix it if it is affected.

What it is: CVE-2025-14847 is a high-severity vulnerability in Mongodb Mongodb, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-14847 in the wild since at least 29 Dec 2025.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 4.4.0; fixed in 4.4.30, 5.0.32, 6.0.27, 7.0.28, 8.0.17, 8.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14847/ (Markdown: https://insights.sbomify.com/CVE-2025-14847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14847
- OSV: https://osv.dev/vulnerability/CVE-2025-14847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14847/
Summaries are generated and may contain mistakes; the official description above is the record.
