# CVE-2025-14969: Hibernate-reactive-core: hibernate reactive: denial of service due to connection leak on http client disconnect

> Remote attackers can cause denial of service by prematurely closing HTTP connections, leaking database connections in Hibernate Reactive applications.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-frpp-8pwq-hjrx

## What is CVE-2025-14969?

CVE-2025-14969 is a medium-severity denial of service vulnerability in Red Hat JBoss Enterprise Application Platform 8, published on 26 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Hibernate Reactive. When an HTTP endpoint is exposed to perform database operations, a remote client can prematurely close the HTTP connection. This action may lead to leaking connections from the database connection pool, potentially causing a Denial of Service (DoS) by exhausting available database connections.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2025-14969?

2 open source packages ship an affected version, including org.hibernate.reactive:hibernate-reactive-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.hibernate.reactive:hibernate-reactive-core` | Maven | All versions | 4.2.1 |
| `org.hibernate.reactive:hibernate-reactive-core` | Maven | All versions | 4.2.1 |

## How do I fix CVE-2025-14969?

Upgrade org.hibernate.reactive:hibernate-reactive-core to 4.2.1 or later.

## Is CVE-2025-14969 being exploited?

There is no known exploitation of CVE-2025-14969 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14969 and fix it if it is affected.

What it is: CVE-2025-14969 is a medium-severity denial of service vulnerability in Red Hat JBoss Enterprise Application Platform 8, published on 26 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-14969 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.hibernate.reactive:hibernate-reactive-core (Maven): affected all versions; fixed in 4.2.1
- org.hibernate.reactive:hibernate-reactive-core (Maven): affected all versions; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14969/ (Markdown: https://insights.sbomify.com/CVE-2025-14969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14969
- OSV: https://osv.dev/vulnerability/CVE-2025-14969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14969/
Summaries are generated and may contain mistakes; the official description above is the record.
