{"answers":{"affected":"3 open source packages ship an affected version, including plotai. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-1497 in the wild and no public exploit code.","fix":"Upgrade plotai to 0.0.7 or later.","what":"CVE-2025-1497 is a critical code injection vulnerability in MLJAR PlotAI, published on 10 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1497 and fix it if it is affected.\n\nWhat it is: CVE-2025-1497 is a critical code injection vulnerability in MLJAR PlotAI, published on 10 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-1497 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plotai (PyPI): affected all versions; fixed in 0.0.7\n- plotai (PyPI): affected all versions; fixed in 0.0.7\n- plotai (PyPI): affected all versions; fixed in 0.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1497/ (Markdown: https://insights.sbomify.com/CVE-2025-1497/index.md)","id":"CVE-2025-1497","markdown":"https://insights.sbomify.com/CVE-2025-1497/index.md","name":"CVE-2025-1497","record":{"aliases":["GHSA-2hmp-5wqg-f24h","PYSEC-2025-22"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python plotting library","requires_auth":"none","summary":"Attackers can execute arbitrary Python code via unvalidated LLM output in PlotAI, requiring manual code modification to exploit.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CERT-PL","cpe":[{"product":"plotai","vendor":"mljar"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"A vulnerability, that could result in Remote Code Execution (RCE), has been found in PlotAI. Lack of validation of LLM-generated output allows attacker to execute arbitrary Python code.\nVendor commented out vulnerable line, further usage of the software requires uncommenting it and thus accepting the risk. The vendor does not plan to release a patch to fix this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote Code Execution in PlotAI","id":"CVE-2025-1497","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"IBM InfoSphere Information Server information disclosure","id":"CVE-2025-1499"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.7"],"introduced":["0"],"last_affected":[],"package":"plotai","purl":null,"source":"GHSA-2hmp-5wqg-f24h"},{"ecosystem":"PyPI","fixed":["0.0.7"],"introduced":["0"],"last_affected":[],"package":"plotai","purl":"pkg:pypi/plotai","source":"GHSA-2hmp-5wqg-f24h"},{"ecosystem":"PyPI","fixed":["0.0.7"],"introduced":["0"],"last_affected":[],"package":"plotai","purl":"pkg:pypi/plotai","source":"PYSEC-2025-22"}],"prev":{"headline":"Improper Authentication in BG-TEK's Coslat Hotspot","id":"CVE-2025-1496"},"products":["PlotAI"],"published":"2025-03-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-03","vendors":["MLJAR"]},"summary":"Attackers can execute arbitrary Python code via unvalidated LLM output in PlotAI, requiring manual code modification to exploit.","url":"https://insights.sbomify.com/CVE-2025-1497/"}