# CVE-2025-1497: Remote Code Execution in PlotAI

> Attackers can execute arbitrary Python code via unvalidated LLM output in PlotAI, requiring manual code modification to exploit.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2025
- **Updated:** 3 Oct 2025
- **Also known as:** GHSA-2hmp-5wqg-f24h, PYSEC-2025-22

## What is CVE-2025-1497?

CVE-2025-1497 is a critical code injection vulnerability in MLJAR PlotAI, published on 10 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability, that could result in Remote Code Execution (RCE), has been found in PlotAI. Lack of validation of LLM-generated output allows attacker to execute arbitrary Python code.
Vendor commented out vulnerable line, further usage of the software requires uncommenting it and thus accepting the risk. The vendor does not plan to release a patch to fix this vulnerability.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-1497?

3 open source packages ship an affected version, including plotai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plotai` | PyPI | All versions | 0.0.7 |
| `plotai` | PyPI | All versions | 0.0.7 |
| `plotai` | PyPI | All versions | 0.0.7 |

Products: Mljar Plotai.

## How do I fix CVE-2025-1497?

Upgrade plotai to 0.0.7 or later.

## Is CVE-2025-1497 being exploited?

There is no known exploitation of CVE-2025-1497 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1497 and fix it if it is affected.

What it is: CVE-2025-1497 is a critical code injection vulnerability in MLJAR PlotAI, published on 10 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-1497 in the wild and no public exploit code.

Affected packages and fixed versions:
- plotai (PyPI): affected all versions; fixed in 0.0.7
- plotai (PyPI): affected all versions; fixed in 0.0.7
- plotai (PyPI): affected all versions; fixed in 0.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1497/ (Markdown: https://insights.sbomify.com/CVE-2025-1497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1497
- OSV: https://osv.dev/vulnerability/CVE-2025-1497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1497/
Summaries are generated and may contain mistakes; the official description above is the record.
