# CVE-2025-14987: Cross Namespace Commands Authorization Bypass

> Attackers can execute workflow commands in unauthorized namespaces, allowing cross-namespace workflow creation, signaling, or cancellation.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2025
- **Updated:** 2 Jan 2026
- **Also known as:** CLEANSTART-2026-HC51017, CLEANSTART-2026-UB40516, ECHO-b73c-fd45-410f, GHSA-hmhp-gh8m-c8xp, GO-2026-4273

## What is CVE-2025-14987?

CVE-2025-14987 is a medium-severity missing authorization vulnerability in Temporal, published on 30 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When system.enableCrossNamespaceCommands is enabled (on by default), the Temporal server permits certain workflow task commands (e.g. StartChildWorkflowExecution, SignalExternalWorkflowExecution, RequestCancelExternalWorkflowExecution) to target a different namespace than the namespace authorized at the gRPC boundary. The frontend authorizes RespondWorkflowTaskCompleted based on the outer request namespace, but the history service later resolves and executes the command using the namespace embedded in command attributes without authorizing the caller for that target namespace. This can allow a worker authorized for one namespace to create, signal, or cancel workflows in another namespace.
This issue affects Temporal: through 1.29.1. Fixed in 1.27.4, 1.28.2, 1.29.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-14987?

9 open source packages ship an affected version, including go.temporal.io/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.temporal.io/server` | Go | All versions | 1.27.4, 1.28.2, 1.29.2 |
| `go.temporal.io/server` | Go | All versions | 1.27.4 |
| `go.temporal.io/server` | Go | All versions | 1.27.4 |
| `go.temporal.io/server` | Go | From 1.28.0 | 1.28.2 |
| `go.temporal.io/server` | Go | From 1.28.0 | 1.28.2 |
| `go.temporal.io/server` | Go | From 1.29.0 | 1.29.2 |
| `go.temporal.io/server` | Go | From 1.29.0 | 1.29.2 |
| `go.temporal.io/server` | Go | From 1.29.0-0 | 1.29.0-135.0.0.20251218190115-b292a32bacdf |
| `go.temporal.io/server` | Go | From 1.29.0-0 | 1.29.0-135.0.0.20251218190115-b292a32bacdf |

## How do I fix CVE-2025-14987?

Upgrade go.temporal.io/server to a fixed version for your release line: 1.27.4, 1.28.2, 1.29.2 or 1.29.0-135.0.0.20251218190115-b292a32bacdf.

## Is CVE-2025-14987 being exploited?

There is no known exploitation of CVE-2025-14987 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-14987 and fix it if it is affected.

What it is: CVE-2025-14987 is a medium-severity missing authorization vulnerability in Temporal, published on 30 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-14987 in the wild and no public exploit code.

Affected packages and fixed versions:
- go.temporal.io/server (Go): affected all versions; fixed in 1.27.4, 1.28.2, 1.29.2
- go.temporal.io/server (Go): affected all versions; fixed in 1.27.4
- go.temporal.io/server (Go): affected all versions; fixed in 1.27.4
- go.temporal.io/server (Go): affected from 1.28.0; fixed in 1.28.2
- go.temporal.io/server (Go): affected from 1.28.0; fixed in 1.28.2
- go.temporal.io/server (Go): affected from 1.29.0; fixed in 1.29.2
- go.temporal.io/server (Go): affected from 1.29.0; fixed in 1.29.2
- go.temporal.io/server (Go): affected from 1.29.0-0; fixed in 1.29.0-135.0.0.20251218190115-b292a32bacdf
- go.temporal.io/server (Go): affected from 1.29.0-0; fixed in 1.29.0-135.0.0.20251218190115-b292a32bacdf

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-14987/ (Markdown: https://insights.sbomify.com/CVE-2025-14987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-14987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-14987
- OSV: https://osv.dev/vulnerability/CVE-2025-14987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-14987/
Summaries are generated and may contain mistakes; the official description above is the record.
