CVE-2025-15033 WooCommerce - Subscriber/Customer+ Order Data Disclosure
Logged-in customers can access guest order data on sites with specific configurations, requiring an upgrade to the latest WooCommerce version.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-15033?
CVE-2025-15033 is a medium-severity vulnerability in Automattic WooCommerce, published on 22 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.
Weakness: CWE-200
Which versions are affected by CVE-2025-15033?
How do I fix CVE-2025-15033?
No fix has been published for CVE-2025-15033 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-15033 being exploited?
There is no known exploitation of CVE-2025-15033 in the wild and no public exploit code.
Sources
Also known as GHSA-q45j-x3cj-gjvq.