{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-15033 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-15033 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-15033 is a medium-severity vulnerability in Automattic WooCommerce, published on 22 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-15033 and fix it if it is affected.\n\nWhat it is: CVE-2025-15033 is a medium-severity vulnerability in Automattic WooCommerce, published on 22 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-15033 in the wild and no public exploit code.\n\nAffected product: Automattic WooCommerce. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-15033/ (Markdown: https://insights.sbomify.com/CVE-2025-15033/index.md)","id":"CVE-2025-15033","markdown":"https://insights.sbomify.com/CVE-2025-15033/index.md","name":"CVE-2025-15033","record":{"aliases":["GHSA-q45j-x3cj-gjvq"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"WooCommerce plugin","requires_auth":"low_privilege","summary":"Logged-in customers can access guest order data on sites with specific configurations, requiring an upgrade to the latest WooCommerce version.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WooCommerce - Subscriber/Customer+ Order Data Disclosure","id":"CVE-2025-15033","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"itsourcecode Student Management System record.php sql injection","id":"CVE-2025-15034"},"packages":[],"prev":{"headline":"CVE-2025-15032: Increased Spoofing risk; custom new window missing about:blank","id":"CVE-2025-15032"},"products":["WooCommerce"],"published":"2025-12-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-06","vendors":["Automattic"]},"summary":"Logged-in customers can access guest order data on sites with specific configurations, requiring an upgrade to the latest WooCommerce version.","url":"https://insights.sbomify.com/CVE-2025-15033/"}