# CVE-2025-15036: Path Traversal Vulnerability in mlflow/mlflow

> Attackers can exploit path traversal in archive extraction to overwrite files or escalate privileges in MLflow environments.

- **Severity:** Critical 9.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-mlflow-2025-15036, GHSA-vhcx-3pq2-4fvc, PYSEC-2026-425

## What is CVE-2025-15036?

CVE-2025-15036 is a critical path traversal vulnerability in Lfprojects Mlflow, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A path traversal vulnerability exists in the `extract_archive_to_dir` function within the `mlflow/pyfunc/dbconnect_artifact_cache.py` file of the mlflow/mlflow repository. This vulnerability, present in versions before v3.7.0, arises due to the lack of validation of tar member paths during extraction. An attacker with control over the tar.gz file can exploit this issue to overwrite arbitrary files or gain elevated privileges, potentially escaping the sandbox directory in multi-tenant or shared cluster environments.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-29 (Path Traversal: '\..\filename')

## Which versions are affected by CVE-2025-15036?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.9.0 |
| `mlflow` | PyPI | All versions | 3.9.0rc0 |
| `mlflow` | PyPI | All versions | 3.9.0rc0 |
| `mlflow` | PyPI | All versions | 3.9.0rc0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2025-15036?

Upgrade mlflow to a fixed version for your release line: 3.9.0 or 3.9.0rc0.

## Is CVE-2025-15036 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15036 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15036 and fix it if it is affected.

What it is: CVE-2025-15036 is a critical path traversal vulnerability in Lfprojects Mlflow, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15036 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.9.0
- mlflow (PyPI): affected all versions; fixed in 3.9.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.9.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.9.0rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15036/ (Markdown: https://insights.sbomify.com/CVE-2025-15036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15036
- OSV: https://osv.dev/vulnerability/CVE-2025-15036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15036/
Summaries are generated and may contain mistakes; the official description above is the record.
