# CVE-2025-15135: A weakness has been identified in joey-zhou xiaozhi-esp32-server-java up to 3.0.0.


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 28 Dec 2025
- **Updated:** 29 Dec 2025
- **Also known as:** GHSA-7x46-g3w8-h64v

## What is CVE-2025-15135?

CVE-2025-15135 is a medium-severity vulnerability in joey-zhou xiaozhi-esp32-server-java, published on 28 Dec 2025. 

### Official description

A weakness has been identified in joey-zhou xiaozhi-esp32-server-java up to 3.0.0. This impacts the function tryAuthenticateWithCookies of the file AuthenticationInterceptor.java of the component Cookie Handler. Executing manipulation can lead to improper authentication. The attack can be launched remotely. The exploit has been made available to the public and could be exploited. Upgrading to version 4.0.0 will fix this issue. It is recommended to upgrade the affected component.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-15135?


## How do I fix CVE-2025-15135?

No fix has been published for CVE-2025-15135 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-15135 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15135 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15135 and fix it if it is affected.

What it is: CVE-2025-15135 is a medium-severity vulnerability in joey-zhou xiaozhi-esp32-server-java, published on 28 Dec 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15135 exists.

Affected product: joey-zhou xiaozhi-esp32-server-java. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15135/ (Markdown: https://insights.sbomify.com/CVE-2025-15135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15135
- OSV: https://osv.dev/vulnerability/CVE-2025-15135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15135/
Summaries are generated and may contain mistakes; the official description above is the record.
