# CVE-2025-15241: CloudPanel Community Edition HTTP Header users redirect


- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 30 Dec 2025
- **Updated:** 30 Dec 2025
- **Also known as:** GHSA-7q3r-qjrg-8grj

## What is CVE-2025-15241?

CVE-2025-15241 is a medium-severity vulnerability in CloudPanel Community Edition, published on 30 Dec 2025. 

### Official description

A security vulnerability has been detected in CloudPanel Community Edition up to 2.5.1. The affected element is an unknown function of the file /admin/users of the component HTTP Header Handler. Such manipulation of the argument Referer leads to open redirect. It is possible to launch the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.5.2 is sufficient to fix this issue. Upgrading the affected component is recommended.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-15241?


## How do I fix CVE-2025-15241?

No fix has been published for CVE-2025-15241 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-15241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15241 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15241 and fix it if it is affected.

What it is: CVE-2025-15241 is a medium-severity vulnerability in CloudPanel Community Edition, published on 30 Dec 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15241 exists.

Affected product: CloudPanel Community Edition. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15241/ (Markdown: https://insights.sbomify.com/CVE-2025-15241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15241
- OSV: https://osv.dev/vulnerability/CVE-2025-15241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15241/
Summaries are generated and may contain mistakes; the official description above is the record.
