# CVE-2025-15284: arrayLimit bypass in bracket notation allows DoS via memory exhaustion

> Attackers can cause memory exhaustion via bracket notation if parameterLimit is increased, bypassing arrayLimit checks in the qs library.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Dec 2025
- **Updated:** 10 Feb 2026
- **Also known as:** AZL-73316, AZL-73319, AZL-73353, AZL-73359, CLEANSTART-2026-BM16290, CLSA-2026-1773274548, CLSA-2026-1776299673, CLSA-2026-1791626635, CLSA-2026-1791806891, CLSA-2026-1792160905, DEBIAN-CVE-2025-15284, ECHO-d529-47d7-7d1b, GHSA-6rw7-vpxm-498p, MINI-2hjr-5wc7-g7x4, MINI-4p8v-g6w4-63hj, MINI-53mj-xjgj-7c68, MINI-5j8v-8jp9-mw2g, MINI-5m3r-m39q-v7jg, MINI-65p2-m2xq-gjv2, MINI-9cwv-g765-fcw6, MINI-9g82-6ghp-7pc5, MINI-c9gj-h97c-9hqm, MINI-g7w3-rhxj-c862, MINI-gqwv-8r9g-8w5c, MINI-hx84-p2g2-85h6, MINI-m5p3-6j3g-4jf4, MINI-m86x-x9mq-fh43, MINI-m8vr-h9h6-wj2x, MINI-mx53-6gx4-hxmj, MINI-qgj5-jhr3-pg47, MINI-rgp7-jgf9-54jg, MINI-v26j-4xp8-852f, ROOT-APP-NPM-CVE-2025-15284, UBUNTU-CVE-2025-15284

## What is CVE-2025-15284?

CVE-2025-15284 is a medium-severity denial of service vulnerability in qs_project:qs, published on 29 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in qs (parse modules) allows HTTP DoS.This issue affects qs: < 6.14.1.

Summary

The arrayLimit option in qs did not enforce limits for bracket notation (a[]=1&a[]=2), only for indexed notation (a[0]=1). This is a consistency bug; arrayLimit should apply uniformly across all array notations.

Note: The default parameterLimit of 1000 effectively mitigates the DoS scenario originally described. With default options, bracket notation cannot produce arrays larger than parameterLimit regardless of arrayLimit, because each a[]=valueconsumes one parameter slot. The severity has been reduced accordingly.

Details

The arrayLimit option only checked limits for indexed notation (a[0]=1&a[1]=2) but did not enforce it for bracket notation (a[]=1&a[]=2).

Vulnerable code (lib/parse.js:159-162):

if (root === '[]' && options.parseArrays) {
    obj = utils.combine([], leaf);  // No arrayLimit check
}

Working code (lib/parse.js:175):

else if (index <= options.arrayLimit) {  // Limit checked here
    obj = [];
    obj[index] = leaf;
}

The bracket notation handler at line 159 uses utils.combine([], leaf) without validating against options.arrayLimit, while indexed notation at line 175 checks index <= options.arrayLimit before creating arrays.

PoC

const qs = require('qs');
const result = qs.parse('a[]=1&a[]=2&a[]=3&a[]=4&a[]=5&a[]=6', { arrayLimit: 5 });
console.log(result.a.length);  // Output: 6 (should be max 5)

Note on parameterLimit interaction: The original advisory's "DoS demonstration" claimed a length of 10,000, but parameterLimit (default: 1000) caps parsing to 1,000 parameters. With default options, the actual output is 1,000, not 10,000.

Impact

Consistency bug in arrayLimit enforcement. With default parameterLimit, the practical DoS risk is negligible since parameterLimit already caps the total number of parsed parameters (and thus array elements from bracket notation). The risk increases only when parameterLimit is explicitly set to a very high value.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-15284?

2 open source packages ship an affected version, including qs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qs` | npm | All versions | 6.14.1 |
| `qs` | npm | All versions | 6.14.1 |

Products: Qs Project Qs.

## How do I fix CVE-2025-15284?

Upgrade qs to 6.14.1 or later.

## Is CVE-2025-15284 being exploited?

There is no known exploitation of CVE-2025-15284 in the wild and no public exploit code.

## Other vulnerabilities in qs_project:qs

- [CVE-2014-10064](https://insights.sbomify.com/CVE-2014-10064/): Denial-of-Service Extended Event Loop Blocking in qs (high 7.5)
- [CVE-2017-1000048](https://insights.sbomify.com/CVE-2017-1000048/): Prototype Pollution Protection Bypass in qs (high 7.5)
- [CVE-2026-2391](https://insights.sbomify.com/CVE-2026-2391/): qs's arrayLimit bypass in comma parsing allows denial of service (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15284 and fix it if it is affected.

What it is: CVE-2025-15284 is a medium-severity denial of service vulnerability in qs_project:qs, published on 29 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-15284 in the wild and no public exploit code.

Affected packages and fixed versions:
- qs (npm): affected all versions; fixed in 6.14.1
- qs (npm): affected all versions; fixed in 6.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15284/ (Markdown: https://insights.sbomify.com/CVE-2025-15284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15284
- OSV: https://osv.dev/vulnerability/CVE-2025-15284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15284/
Summaries are generated and may contain mistakes; the official description above is the record.
