{"answers":{"affected":"3 open source packages ship an affected version, including wolfssl.","exploited":"There is no known exploitation of CVE-2025-15346 in the wild and no public exploit code.","fix":"Upgrade wolfssl to 5.8.4.post0 or later.","what":"CVE-2025-15346 is a critical authentication bypass vulnerability in wolfSSL-py, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-15346 and fix it if it is affected.\n\nWhat it is: CVE-2025-15346 is a critical authentication bypass vulnerability in wolfSSL-py, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-15346 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wolfssl (PyPI): affected all versions; fixed in 5.8.4.post0\n- wolfssl (PyPI): affected all versions; fixed in 5.8.4.post0\n- wolfssl (PyPI): affected all versions; fixed in 5.8.4.post0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-15346/ (Markdown: https://insights.sbomify.com/CVE-2025-15346/index.md)","id":"CVE-2025-15346","markdown":"https://insights.sbomify.com/CVE-2025-15346/index.md","name":"CVE-2025-15346","record":{"aliases":["GHSA-vj87-jj27-4h9c","PYSEC-2026-575"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python TLS library","requires_auth":"none","summary":"Attackers can bypass mutual TLS authentication by omitting client certificates when CERT_REQUIRED is configured, allowing unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"wolfSSL","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/AU:Y","version":"4.0"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"A vulnerability in the handling of verify_mode = CERT_REQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate requirements to not be fully enforced. \n\nBecause the WOLFSSL_VERIFY_FAIL_IF_NO_PEER_CERT flag was not included, the behavior effectively matched CERT_OPTIONAL: a peer certificate was verified if presented, but connections were incorrectly authenticated when no client certificate was provided. \n\nThis results in improper authentication, allowing attackers to bypass mutual TLS (mTLS) client authentication by omitting a client certificate during the TLS handshake. \n\nThe issue affects versions up to and including 5.8.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"wolfSSL Python library `CERT_REQUIRED` mode fails to enforce client certificate requirement","id":"CVE-2025-15346","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"Missing authorization in Creator LMS – Online Courses and eLearning Plugin","id":"CVE-2025-15347"},"packages":[{"ecosystem":"PyPI","fixed":["5.8.4.post0"],"introduced":["0"],"last_affected":[],"package":"wolfssl","purl":null,"source":"GHSA-vj87-jj27-4h9c"},{"ecosystem":"PyPI","fixed":["5.8.4.post0"],"introduced":["0"],"last_affected":[],"package":"wolfssl","purl":"pkg:pypi/wolfssl","source":"GHSA-vj87-jj27-4h9c"},{"ecosystem":"PyPI","fixed":["5.8.4.post0"],"introduced":["0"],"last_affected":[],"package":"wolfssl","purl":"pkg:pypi/wolfssl","source":"PYSEC-2026-575"}],"prev":{"headline":"MapGeo - Interactive Geo Maps \u003c= 1.6.27 - Reflected Cross-Site Scripting via 'map' Parameter","id":"CVE-2025-15345"},"products":["wolfSSL-py"],"published":"2026-01-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-08","vendors":["wolfSSL"]},"summary":"Attackers can bypass mutual TLS authentication by omitting client certificates when CERT_REQUIRED is configured, allowing unauthorized access.","url":"https://insights.sbomify.com/CVE-2025-15346/"}