# CVE-2025-15346: wolfSSL Python library `CERT_REQUIRED` mode fails to enforce client certificate requirement

> Attackers can bypass mutual TLS authentication by omitting client certificates when CERT_REQUIRED is configured, allowing unauthorized access.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/AU:Y`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2026
- **Updated:** 8 Jan 2026
- **Also known as:** GHSA-vj87-jj27-4h9c, PYSEC-2026-575

## What is CVE-2025-15346?

CVE-2025-15346 is a critical authentication bypass vulnerability in wolfSSL-py, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the handling of verify_mode = CERT_REQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate requirements to not be fully enforced. 

Because the WOLFSSL_VERIFY_FAIL_IF_NO_PEER_CERT flag was not included, the behavior effectively matched CERT_OPTIONAL: a peer certificate was verified if presented, but connections were incorrectly authenticated when no client certificate was provided. 

This results in improper authentication, allowing attackers to bypass mutual TLS (mTLS) client authentication by omitting a client certificate during the TLS handshake. 

The issue affects versions up to and including 5.8.2.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-15346?

3 open source packages ship an affected version, including wolfssl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wolfssl` | PyPI | All versions | 5.8.4.post0 |
| `wolfssl` | PyPI | All versions | 5.8.4.post0 |
| `wolfssl` | PyPI | All versions | 5.8.4.post0 |

## How do I fix CVE-2025-15346?

Upgrade wolfssl to 5.8.4.post0 or later.

## Is CVE-2025-15346 being exploited?

There is no known exploitation of CVE-2025-15346 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15346 and fix it if it is affected.

What it is: CVE-2025-15346 is a critical authentication bypass vulnerability in wolfSSL-py, published on 7 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-15346 in the wild and no public exploit code.

Affected packages and fixed versions:
- wolfssl (PyPI): affected all versions; fixed in 5.8.4.post0
- wolfssl (PyPI): affected all versions; fixed in 5.8.4.post0
- wolfssl (PyPI): affected all versions; fixed in 5.8.4.post0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15346/ (Markdown: https://insights.sbomify.com/CVE-2025-15346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15346
- OSV: https://osv.dev/vulnerability/CVE-2025-15346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15346/
Summaries are generated and may contain mistakes; the official description above is the record.
