# CVE-2025-15367: POP3 command injection in user-controlled commands

> Attackers can inject commands into the Python poplib module via user-controlled input, potentially leading to code execution.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2026
- **Updated:** 26 Feb 2026
- **Also known as:** AZL-75038, AZL-75050, AZL-84269, BELL-CVE-2025-15367, BIT-libpython-2025-15367, BIT-python-2025-15367, BIT-python-min-2025-15367, CLSA-2026-1771597605, CLSA-2026-1771930823, CLSA-2026-1771931183, CLSA-2026-1772098033, CLSA-2026-1772103023, CLSA-2026-1774520206, CLSA-2026-1775059689, CLSA-2026-1775222005, CLSA-2026-1775223681, DEBIAN-CVE-2025-15367, ECHO-077b-81db-c985, GHSA-g82h-mgfp-jx8g, MINI-cv59-332m-5cpq, MINI-fxhm-fpf4-7q58, MINI-g63c-73wp-wqpq, MINI-rmxr-wc9h-7mx8, MINI-vccr-rx6c-xxw5, PSF-2026-4, RHSA-2026:5994, ROOT-OS-DEBIAN-12-CVE-2025-15367, ROOT-OS-DEBIAN-13-CVE-2025-15367, UBUNTU-CVE-2025-15367

## What is CVE-2025-15367?

CVE-2025-15367 is a medium-severity command injection vulnerability in CPython, published on 20 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The poplib module, when passed a user-controlled command, can have
additional commands injected using newlines. Mitigation rejects commands
containing control characters.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-15367?

3 open source packages ship an affected version, including libpython, python and python-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.15.0 |
| `python` | Bitnami | All versions | 3.15.0 |
| `python-min` | Bitnami | All versions | 3.15.0 |
| `python-unversioned-command` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3-debug` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3-devel` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3-idle` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3-libs` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3-test` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3-tkinter` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3.14` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3.14-freethreading` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3.14-freethreading-debug` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3.14-freethreading-devel` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3.14-freethreading-idle` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3.14-freethreading-libs` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3.14-freethreading-test` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |
| `python3.14-freethreading-tkinter` | Red Hat:hummingbird:1 | All versions | 0:3.14.3-2.hum1 |

## How do I fix CVE-2025-15367?

Upgrade libpython to 3.15.0 or later.

## Is CVE-2025-15367 being exploited?

There is no known exploitation of CVE-2025-15367 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15367 and fix it if it is affected.

What it is: CVE-2025-15367 is a medium-severity command injection vulnerability in CPython, published on 20 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-15367 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.15.0
- python (Bitnami): affected all versions; fixed in 3.15.0
- python-min (Bitnami): affected all versions; fixed in 3.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15367/ (Markdown: https://insights.sbomify.com/CVE-2025-15367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15367
- OSV: https://osv.dev/vulnerability/CVE-2025-15367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15367/
Summaries are generated and may contain mistakes; the official description above is the record.
