# CVE-2025-15379: Command Injection in mlflow/mlflow

> Attackers can execute arbitrary commands by providing malicious model artifacts when deploying with local environment manager.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2026
- **Updated:** 7 Sep 2026
- **Also known as:** BIT-mlflow-2025-15379, GHSA-r23q-823p-vmf7, PYSEC-2026-423

## What is CVE-2025-15379?

CVE-2025-15379 is a critical command injection vulnerability in Lfprojects Mlflow, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A command injection vulnerability exists in MLflow's model serving container initialization code, specifically in the `_install_model_dependencies_to_env()` function. When deploying a model with `env_manager=LOCAL`, MLflow reads dependency specifications from the model artifact's `python_env.yaml` file and directly interpolates them into a shell command without sanitization. This allows an attacker to supply a malicious model artifact and achieve arbitrary command execution on systems that deploy the model. The vulnerability affects versions 3.8.0 and is fixed in version 3.8.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-15379?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | From 3.8.0 | 3.8.1 |
| `mlflow` | PyPI | All versions | 3.8.1 |
| `mlflow` | PyPI | All versions | 3.8.1 |
| `mlflow` | PyPI | All versions | 3.8.1 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2025-15379?

Upgrade mlflow to 3.8.1 or later.

## Is CVE-2025-15379 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15379 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)
- [CVE-2023-6015](https://insights.sbomify.com/CVE-2023-6015/): MLflow Arbitrary File Upload (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15379 and fix it if it is affected.

What it is: CVE-2025-15379 is a critical command injection vulnerability in Lfprojects Mlflow, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15379 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected from 3.8.0; fixed in 3.8.1
- mlflow (PyPI): affected all versions; fixed in 3.8.1
- mlflow (PyPI): affected all versions; fixed in 3.8.1
- mlflow (PyPI): affected all versions; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15379/ (Markdown: https://insights.sbomify.com/CVE-2025-15379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15379
- OSV: https://osv.dev/vulnerability/CVE-2025-15379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15379/
Summaries are generated and may contain mistakes; the official description above is the record.
