CVE-2025-15437 LigeroSmart Environment Variable cross site scripting
Remote attackers can execute arbitrary scripts via the REQUEST_URI environment variable in LigeroSmart, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-15437?
CVE-2025-15437 is a medium-severity cross-site scripting vulnerability in LigeroSmart, published on 2 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A vulnerability was found in LigeroSmart up to 6.1.24. This affects an unknown part of the component Environment Variable Handler. Performing a manipulation of the argument REQUEST_URI results in cross site scripting. The attack may be initiated remotely. The exploit has been made public and could be used. Upgrading to version 6.1.26 and 6.3 is able to mitigate this issue. The patch is named 264ac5b2be5b3c673ebd8cb862e673f5d300d9a7. The affected component should be upgraded.
Which versions are affected by CVE-2025-15437?
It affects 1 product.
Products include Ligerosmart Ligerosmart.
How do I fix CVE-2025-15437?
No fix has been published for CVE-2025-15437 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-15437 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15437 exists.
Other vulnerabilities in LigeroSmart
Sources
Also known as GHSA-6q3r-7qmf-2jrm.