{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15437 exists.","fix":"No fix has been published for CVE-2025-15437 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-15437 is a medium-severity cross-site scripting vulnerability in LigeroSmart, published on 2 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-15437 and fix it if it is affected.\n\nWhat it is: CVE-2025-15437 is a medium-severity cross-site scripting vulnerability in LigeroSmart, published on 2 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15437 exists.\n\nAffected product: LigeroSmart. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-15437/ (Markdown: https://insights.sbomify.com/CVE-2025-15437/index.md)","id":"CVE-2025-15437","markdown":"https://insights.sbomify.com/CVE-2025-15437/index.md","name":"CVE-2025-15437","record":{"aliases":["GHSA-6q3r-7qmf-2jrm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LigeroSmart application","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the REQUEST_URI environment variable in LigeroSmart, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ligerosmart","vendor":"ligerosmart"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in LigeroSmart up to 6.1.24. This affects an unknown part of the component Environment Variable Handler. Performing a manipulation of the argument REQUEST_URI results in cross site scripting. The attack may be initiated remotely. The exploit has been made public and could be used. Upgrading to version 6.1.26 and 6.3 is able to mitigate this issue. The patch is named 264ac5b2be5b3c673ebd8cb862e673f5d300d9a7. The affected component should be upgraded.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"LigeroSmart Environment Variable cross site scripting","id":"CVE-2025-15437","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":8,"next":{"headline":"PluXml Media Management medias.php __destruct deserialization","id":"CVE-2025-15438"},"packages":[],"prev":{"headline":"Yonyou KSOA work_edit.jsp sql injection","id":"CVE-2025-15436"},"products":["LigeroSmart"],"published":"2026-01-02","related":[{"cvss_score":5.1,"headline":"LigeroSmart index.pl cross site scripting","id":"CVE-2026-2545","kev_date_added":null,"published":"2026-02-16"},{"cvss_score":5.1,"headline":"LigeroSmart index.pl cross site scripting","id":"CVE-2026-2546","kev_date_added":null,"published":"2026-02-16"},{"cvss_score":5.1,"headline":"LigeroSmart index.pl AgentDashboard cross site scripting","id":"CVE-2026-2547","kev_date_added":null,"published":"2026-02-16"},{"cvss_score":5.1,"headline":"LigeroSmart index.pl cross site scripting","id":"CVE-2026-1048","kev_date_added":null,"published":"2026-01-17"},{"cvss_score":5.1,"headline":"LigeroSmart index.pl cross site scripting","id":"CVE-2026-1049","kev_date_added":null,"published":"2026-01-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-23","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary scripts via the REQUEST_URI environment variable in LigeroSmart, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2025-15437/"}