# CVE-2025-15444: Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium

> An attacker can bypass cryptographic validation checks in specific custom use cases by exploiting improper elliptic curve point validation in the bundled libsodium library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2026
- **Updated:** 6 Jan 2026
- **Also known as:** AZL-73751, AZL-73755, GHSA-38vq-9wrc-xxh4, SUSE-SU-2026:0194-1, SUSE-SU-2026:0223-1, SUSE-SU-2026:20242-1, SUSE-SU-2026:20354-1, SUSE-SU-2026:20756-1, SUSE-SU-2026:20913-1, openSUSE-SU-2026:10022-1, openSUSE-SU-2026:20399-1

## What is CVE-2025-15444?

CVE-2025-15444 is a critical vulnerability in IAMB Crypt::Sodium::XS, published on 6 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium

libsodium <= 1.0.20 or a version of libsodium released before December 30, 2025 contains a vulnerability documented as CVE-2025-69277  https://www.cve.org/CVERecord?id=CVE-2025-69277 .

The libsodium vulnerability states:

In atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group.

0.000042 includes a version of libsodium updated to 1.0.20-stable, released January 3, 2026, which includes a fix for the vulnerability.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-1395 (Dependency on Vulnerable Third-Party Component)

## Which versions are affected by CVE-2025-15444?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libsodium` | SUSE:Linux Enterprise Micro 5.2 | All versions | 1.0.18-150000.4.11.1 |
| `libsodium` | SUSE:Linux Enterprise Micro 5.3 | All versions | 1.0.18-150000.4.11.1 |
| `libsodium` | SUSE:Linux Enterprise Micro 5.4 | All versions | 1.0.18-150000.4.11.1 |
| `libsodium` | SUSE:Linux Enterprise Micro 5.5 | All versions | 1.0.18-150000.4.11.1 |
| `libsodium` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 1.0.18-150000.4.11.1 |
| `libsodium` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 1.0.16-1.12.1 |
| `libsodium` | SUSE:Linux Enterprise Server 16.0 | All versions | 1.0.20-160000.3.1 |
| `libsodium` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 1.0.20-160000.3.1 |
| `libsodium` | SUSE:Linux Micro 6.0 | All versions | 1.0.18-4.1 |
| `libsodium` | SUSE:Linux Micro 6.1 | All versions | 1.0.18-slfo.1.1_2.1 |
| `libsodium` | SUSE:Linux Micro 6.2 | All versions | 1.0.20-160000.3.1 |
| `libsodium` | openSUSE:Leap 15.6 | All versions | 1.0.18-150000.4.11.1 |
| `libsodium` | openSUSE:Leap 16.0 | All versions | 1.0.20-160000.3.1 |
| `libsodium` | openSUSE:Tumbleweed | All versions | 1.0.21-1.1 |

Products: Iamb Crypt\.

## How do I fix CVE-2025-15444?

Upgrade to a fixed version.

## Is CVE-2025-15444 being exploited?

There is no known exploitation of CVE-2025-15444 in the wild and no public exploit code.

## Other vulnerabilities in IAMB Crypt::Sodium::XS

- [CVE-2026-30910](https://insights.sbomify.com/CVE-2026-30910/): Crypt::Sodium::XS versions through 0.001000 for Perl has potential integer overflows (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15444 and fix it if it is affected.

What it is: CVE-2025-15444 is a critical vulnerability in IAMB Crypt::Sodium::XS, published on 6 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-15444 in the wild and no public exploit code.

Affected product: IAMB Crypt::Sodium::XS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15444/ (Markdown: https://insights.sbomify.com/CVE-2025-15444/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15444
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15444
- OSV: https://osv.dev/vulnerability/CVE-2025-15444

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15444/
Summaries are generated and may contain mistakes; the official description above is the record.
