{"answers":{"affected":"3 open source packages ship an affected version, including opencolorio.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15506 exists.","fix":"Upgrade opencolorio to 2.5.1 or later.","what":"CVE-2025-15506 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation OpenColorIO, published on 11 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-15506 and fix it if it is affected.\n\nWhat it is: CVE-2025-15506 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation OpenColorIO, published on 11 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15506 exists.\n\nAffected packages and fixed versions:\n- opencolorio (PyPI): affected all versions; fixed in 2.5.1\n- opencolorio (PyPI): affected all versions; fixed in 2.5.1\n- opencolorio (PyPI): affected all versions; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-15506/ (Markdown: https://insights.sbomify.com/CVE-2025-15506/index.md)","id":"CVE-2025-15506","markdown":"https://insights.sbomify.com/CVE-2025-15506/index.md","name":"CVE-2025-15506","record":{"aliases":["DEBIAN-CVE-2025-15506","GHSA-m86r-wr74-693h","PYSEC-2026-1745","UBUNTU-CVE-2025-15506"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenColorIO library","requires_auth":"low_privilege","summary":"A local attacker can trigger an out-of-bounds read in OpenColorIO, potentially causing a crash or leaking memory contents.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability was found in AcademySoftwareFoundation OpenColorIO up to 2.5.0. This issue affects the function ConvertToRegularExpression of the file src/OpenColorIO/FileRules.cpp. Performing a manipulation results in out-of-bounds read. The attack needs to be approached locally. The exploit has been made public and could be used. The patch is named ebdbb75123c9d5f4643e041314e2bc988a13f20d. To fix this issue, it is recommended to deploy a patch. The fix was added to the 2.5.1 milestone.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"AcademySoftwareFoundation OpenColorIO FileRules.cpp ConvertToRegularExpression out-of-bounds","id":"CVE-2025-15506","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":3,"n_references":9,"next":{"headline":"Magic Import Document Extractor \u003c= 1.0.5 - Missing Authorization to Unauthenticated Plugin License Status Modification","id":"CVE-2025-15507"},"packages":[{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"opencolorio","purl":null,"source":"GHSA-m86r-wr74-693h"},{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"opencolorio","purl":"pkg:pypi/opencolorio","source":"GHSA-m86r-wr74-693h"},{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"opencolorio","purl":"pkg:pypi/opencolorio","source":"PYSEC-2026-1745"}],"prev":{"headline":"Luxul XWR-600 Web Administration cross site scripting","id":"CVE-2025-15505"},"products":["OpenColorIO"],"published":"2026-01-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-23","vendors":["AcademySoftwareFoundation"]},"summary":"A local attacker can trigger an out-of-bounds read in OpenColorIO, potentially causing a crash or leaking memory contents.","url":"https://insights.sbomify.com/CVE-2025-15506/"}