# CVE-2025-15506: AcademySoftwareFoundation OpenColorIO FileRules.cpp ConvertToRegularExpression out-of-bounds

> A local attacker can trigger an out-of-bounds read in OpenColorIO, potentially causing a crash or leaking memory contents.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2026
- **Updated:** 23 Feb 2026
- **Also known as:** DEBIAN-CVE-2025-15506, GHSA-m86r-wr74-693h, PYSEC-2026-1745, UBUNTU-CVE-2025-15506

## What is CVE-2025-15506?

CVE-2025-15506 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation OpenColorIO, published on 11 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in AcademySoftwareFoundation OpenColorIO up to 2.5.0. This issue affects the function ConvertToRegularExpression of the file src/OpenColorIO/FileRules.cpp. Performing a manipulation results in out-of-bounds read. The attack needs to be approached locally. The exploit has been made public and could be used. The patch is named ebdbb75123c9d5f4643e041314e2bc988a13f20d. To fix this issue, it is recommended to deploy a patch. The fix was added to the 2.5.1 milestone.

Weakness: CWE-125 (Out-of-bounds Read), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-15506?

3 open source packages ship an affected version, including opencolorio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencolorio` | PyPI | All versions | 2.5.1 |
| `opencolorio` | PyPI | All versions | 2.5.1 |
| `opencolorio` | PyPI | All versions | 2.5.1 |

## How do I fix CVE-2025-15506?

Upgrade opencolorio to 2.5.1 or later.

## Is CVE-2025-15506 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15506 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15506 and fix it if it is affected.

What it is: CVE-2025-15506 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation OpenColorIO, published on 11 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15506 exists.

Affected packages and fixed versions:
- opencolorio (PyPI): affected all versions; fixed in 2.5.1
- opencolorio (PyPI): affected all versions; fixed in 2.5.1
- opencolorio (PyPI): affected all versions; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15506/ (Markdown: https://insights.sbomify.com/CVE-2025-15506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15506
- OSV: https://osv.dev/vulnerability/CVE-2025-15506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15506/
Summaries are generated and may contain mistakes; the official description above is the record.
