{"answers":{"affected":"2 open source packages ship an affected version, including opencc. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15536 exists.","fix":"Upgrade opencc to 1.2.0 or later.","what":"CVE-2025-15536 is a medium-severity memory corruption vulnerability in BYVoid OpenCC, published on 18 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-15536 and fix it if it is affected.\n\nWhat it is: CVE-2025-15536 is a medium-severity memory corruption vulnerability in BYVoid OpenCC, published on 18 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15536 exists.\n\nAffected packages and fixed versions:\n- opencc (npm): affected all versions; fixed in 1.2.0\n- opencc (npm): affected all versions; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-15536/ (Markdown: https://insights.sbomify.com/CVE-2025-15536/index.md)","id":"CVE-2025-15536","markdown":"https://insights.sbomify.com/CVE-2025-15536/index.md","name":"CVE-2025-15536","record":{"aliases":["AZL-74768","AZL-74790","DEBIAN-CVE-2025-15536","GHSA-5pr6-crvp-2j9f","OESA-2026-1209","OESA-2026-1210","OESA-2026-1211","OESA-2026-1212","OESA-2026-1213","SUSE-SU-2026:21553-1","UBUNTU-CVE-2025-15536","USN-7972-1","USN-7972-2","openSUSE-SU-2026:10102-1","openSUSE-SU-2026:20683-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenCC text conversion library","requires_auth":"low_privilege","summary":"A heap-based buffer overflow in OpenCC allows local attackers to execute arbitrary code or cause denial of service via crafted input.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"open_chinese_convert","vendor":"byvoid"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"},{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A weakness has been identified in BYVoid OpenCC up to 1.1.9. This vulnerability affects the function opencc::MaxMatchSegmentation of the file src/MaxMatchSegmentation.cpp. This manipulation causes heap-based buffer overflow. The attack is restricted to local execution. The exploit has been made available to the public and could be used for attacks. Patch name: 345c9a50ab07018f1b4439776bad78a0d40778ec. To fix this issue, it is recommended to deploy a patch.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"BYVoid OpenCC MaxMatchSegmentation.cpp MaxMatchSegmentation heap-based overflow","id":"CVE-2025-15536","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":3,"n_references":8,"next":{"headline":"Mapnik dbfile.cpp string_value heap-based overflow","id":"CVE-2025-15537"},"packages":[{"ecosystem":"npm","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":null,"source":"GHSA-5pr6-crvp-2j9f"},{"ecosystem":"npm","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:npm/opencc","source":"GHSA-5pr6-crvp-2j9f"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.2.0-1.1"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:rpm/opensuse/opencc\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10102-1"}],"prev":{"headline":"nicbarker clay clay.h Clay__MeasureTextCached null pointer dereference","id":"CVE-2025-15535"},"products":["OpenCC"],"published":"2026-01-18","related":[{"cvss_score":5.5,"headline":"Open Chinese Convert subject to Denial of Service via Out-of-bounds Read","id":"CVE-2018-16982","kev_date_added":null,"published":"2018-09-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-23","vendors":["BYVoid"]},"summary":"A heap-based buffer overflow in OpenCC allows local attackers to execute arbitrary code or cause denial of service via crafted input.","url":"https://insights.sbomify.com/CVE-2025-15536/"}