# CVE-2025-15599: DOMPurify XSS via Textarea Rawtext Bypass in SAFE_FOR_XML

> Attackers can execute JavaScript by bypassing DOMPurify's XML sanitization via textarea rawtext tags, affecting applications using the library.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Mar 2026
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-IS78920, CLEANSTART-2026-OE48815, DEBIAN-CVE-2025-15599, GHSA-v8jm-5vwx-cfxm, MINI-7m2x-wj4h-gqc9, MINI-jg9f-h574-fj9c, MINI-wp9q-vhpc-f58x, ROOT-APP-NPM-CVE-2025-15599, UBUNTU-CVE-2025-15599

## What is CVE-2025-15599?

CVE-2025-15599 is a medium-severity cross-site scripting vulnerability in cure53 DOMPurify, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

DOMPurify 3.1.3 through 3.2.6 and 2.5.3 through 2.5.8 contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting missing textarea rawtext element validation in the SAFE_FOR_XML regex. Attackers can include closing rawtext tags like </textarea> in attribute values to break out of rawtext contexts and execute JavaScript when sanitized output is placed inside rawtext elements. The 3.x branch was fixed in 3.2.7; the 2.x branch was never patched.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-15599?

4 open source packages ship an affected version, including dompurify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompurify` | npm | From 2.5.3 to 2.5.8 | None |
| `dompurify` | npm | From 2.5.3 to 2.5.8 | None |
| `dompurify` | npm | From 3.1.3 | 3.2.7 |
| `dompurify` | npm | From 3.1.3 | 3.2.7 |

Products: Cure53 Dompurify.

## How do I fix CVE-2025-15599?

Upgrade dompurify to 3.2.7 or later.

## Is CVE-2025-15599 being exploited?

There is no known exploitation of CVE-2025-15599 in the wild and no public exploit code.

## Other vulnerabilities in cure53 DOMPurify

- [CVE-2024-47875](https://insights.sbomify.com/CVE-2024-47875/): DOMPurify nesting-based mXSS (critical 10.0)
- [CVE-2024-48910](https://insights.sbomify.com/CVE-2024-48910/): DOMPurify vulnerable to tampering by prototype polution (critical 9.1)
- [CVE-2026-47423](https://insights.sbomify.com/CVE-2026-47423/): DOMPurify XSS via `selectedcontent` re-clone (high 8.2)
- [CVE-2024-45801](https://insights.sbomify.com/CVE-2024-45801/): Tampering by prototype polution in DOMPurify (high 7.3)
- [CVE-2026-49978](https://insights.sbomify.com/CVE-2026-49978/): DOMPurify IN_PLACE Sanitization Bypass via Attached Shadow Root Inside <template>.content (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15599 and fix it if it is affected.

What it is: CVE-2025-15599 is a medium-severity cross-site scripting vulnerability in cure53 DOMPurify, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-15599 in the wild and no public exploit code.

Affected packages and fixed versions:
- dompurify (npm): affected from 2.5.3 up to 2.5.8; no fix listed
- dompurify (npm): affected from 2.5.3 up to 2.5.8; no fix listed
- dompurify (npm): affected from 3.1.3; fixed in 3.2.7
- dompurify (npm): affected from 3.1.3; fixed in 3.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15599/ (Markdown: https://insights.sbomify.com/CVE-2025-15599/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15599
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15599
- OSV: https://osv.dev/vulnerability/CVE-2025-15599

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15599/
Summaries are generated and may contain mistakes; the official description above is the record.
