CVE-2025-15602 Snipe-IT < 8.3.7 Mass Assignment Vulnerability Leading to Privilege Escalation
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-15602?
CVE-2025-15602 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 6 Mar 2026.
Official description
Snipe-IT versions prior to 8.3.7 contain sensitive user attributes related to account privileges that are insufficiently protected against mass assignment. An authenticated, low-privileged user can craft a malicious API request to modify restricted fields of another user account, including the Super Admin account. By changing the email address of the Super Admin and triggering a password reset, an attacker can fully take over the Super Admin account, resulting in complete administrative control of the Snipe-IT instance.
Weakness: CWE-915
Which versions are affected by CVE-2025-15602?
2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
snipe/snipe-it Packagist | All versions | 8.3.7 |
snipe/snipe-it Packagist | All versions | 8.3.7 |
Products include Snipeitapp Snipe-It.
How do I fix CVE-2025-15602?
Upgrade snipe/snipe-it to 8.3.7 or later.
Is CVE-2025-15602 being exploited?
There is no known exploitation of CVE-2025-15602 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Snipeitapp Snipe-It
- CVE-2025-63601 File upload in n/a
- CVE-2026-37709 Snipe-IT has insecure permissions in file uploads
- CVE-2026-86738 Snipe-IT before 8.7.0 CSS Injection via Custom CSS
- CVE-2026-116199 Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback
- CVE-2022-1380 Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it
Sources
Also known as GHSA-5448-v74m-7mv7.