# CVE-2025-15602: Snipe-IT < 8.3.7 Mass Assignment Vulnerability Leading to Privilege Escalation


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-5448-v74m-7mv7

## What is CVE-2025-15602?

CVE-2025-15602 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 6 Mar 2026. 

### Official description

Snipe-IT versions prior to 8.3.7 contain sensitive user attributes related to account privileges that are insufficiently protected against mass assignment. An authenticated, low-privileged user can craft a malicious API request to modify restricted fields of another user account, including the Super Admin account. By changing the email address of the Super Admin and triggering a password reset, an attacker can fully take over the Super Admin account, resulting in complete administrative control of the Snipe-IT instance.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2025-15602?

2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snipe/snipe-it` | Packagist | All versions | 8.3.7 |
| `snipe/snipe-it` | Packagist | All versions | 8.3.7 |

Products: Snipeitapp Snipe-It.

## How do I fix CVE-2025-15602?

Upgrade snipe/snipe-it to 8.3.7 or later.

## Is CVE-2025-15602 being exploited?

There is no known exploitation of CVE-2025-15602 in the wild and no public exploit code.

Public exploit code:

- Snipe-IT < 8.3.7 Mass Assignment Vulnerability Leading to Privilege Escalation (github_poc): https://github.com/Nxvh1337/CVE-2025-15602-PoC

## Other vulnerabilities in Snipeitapp Snipe-It

- [CVE-2025-63601](https://insights.sbomify.com/CVE-2025-63601/): File upload in n/a (critical 9.9)
- [CVE-2026-37709](https://insights.sbomify.com/CVE-2026-37709/): Snipe-IT has insecure permissions in file uploads (critical 9.8)
- [CVE-2026-86738](https://insights.sbomify.com/CVE-2026-86738/): Snipe-IT before 8.7.0 CSS Injection via Custom CSS (critical 9.3)
- [CVE-2026-116199](https://insights.sbomify.com/CVE-2026-116199/): Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback (critical 9.2)
- [CVE-2022-1380](https://insights.sbomify.com/CVE-2022-1380/): Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15602 and fix it if it is affected.

What it is: CVE-2025-15602 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 6 Mar 2026. 
Exploitation: There is no known exploitation of CVE-2025-15602 in the wild and no public exploit code.

Affected packages and fixed versions:
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.3.7
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15602/ (Markdown: https://insights.sbomify.com/CVE-2025-15602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15602
- OSV: https://osv.dev/vulnerability/CVE-2025-15602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15602/
Summaries are generated and may contain mistakes; the official description above is the record.
