# CVE-2025-15613: Kyverno before v1.13.4 SSRF via Service Call

> Attackers with policy creation permissions can exploit SSRF in Kyverno to exfiltrate sensitive cluster data, including secrets, by directing service calls to external servers.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2026
- **Updated:** 1 Sep 2026
- **Also known as:** BIT-kyverno-2025-15613, CLEANSTART-2026-HT74198, GHSA-459x-q9hg-4gpq, GHSA-8g8h-v9pm-r6xg, GO-2025-3615, MINI-249f-gjvh-fwr5, MINI-35wx-4q84-f5r2, MINI-585x-2f4m-3mpq, MINI-5hjw-xp62-rc9m, MINI-6932-7cmc-g93w, MINI-ghr3-q6wv-7p3f, MINI-h7q2-2g6c-c38m, MINI-h8r4-c658-q69g, MINI-jh65-mwh7-m44v, MINI-pmwh-6qxx-6g6x, MINI-pw5r-mxg5-v6m8, MINI-q8m5-w85f-gjpj, MINI-r9pr-w4x3-x5f2, MINI-rw6c-hmcg-2p67, MINI-wh2h-rqqv-2m92, MINI-wv32-r3f9-wvcq, MINI-xg7w-m4vx-w6mj, MINI-xmmh-f7mw-w67v

## What is CVE-2025-15613?

CVE-2025-15613 is a medium-severity server-side request forgery vulnerability in kyverno, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kyverno before v1.13.4 is vulnerable to server-side request forgery (SSRF) via its Service Call functionality. An attacker with permission to create Kyverno (Cluster)Policies can specify an external URL in a policy's apiCall/service configuration; although Service Call is documented for in-cluster services, it also resolves external addresses, allowing requests to an attacker-controlled server. Because policy context data (including contents of Kubernetes resources such as secrets) is sent in these requests, an attacker can exfiltrate sensitive cluster data.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-15613?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | None |
| `github.com/kyverno/kyverno` | Go | All versions to 1.13.4 | None |
| `github.com/kyverno/kyverno` | Go | All versions to 1.13.4 | None |
| `kyverno` | Bitnami | All versions | 1.13.4 |

## How do I fix CVE-2025-15613?

Upgrade to a fixed version.

## Is CVE-2025-15613 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15613 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-15613 and fix it if it is affected.

What it is: CVE-2025-15613 is a medium-severity server-side request forgery vulnerability in kyverno, published on 1 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15613 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; no fix listed
- github.com/kyverno/kyverno (Go): affected all versions up to 1.13.4; no fix listed
- github.com/kyverno/kyverno (Go): affected all versions up to 1.13.4; no fix listed
- kyverno (Bitnami): affected all versions; fixed in 1.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-15613/ (Markdown: https://insights.sbomify.com/CVE-2025-15613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-15613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-15613
- OSV: https://osv.dev/vulnerability/CVE-2025-15613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-15613/
Summaries are generated and may contain mistakes; the official description above is the record.
