CVE-2025-15632 1Panel-dev MaxKB MdPreview chat.ts cross site scripting

Medium 5.1 Published Updated

Remote attackers can execute arbitrary scripts in user browsers via a cross-site scripting flaw in the MdPreview component of MaxKB.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-15632?

CVE-2025-15632 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability has been found in 1Panel-dev MaxKB up to 2.4.2. Impacted is an unknown function of the file ui/src/chat.ts of the component MdPreview. Such manipulation leads to cross site scripting. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.5.0 is recommended to address this issue. The name of the patch is 7230daa5ec3e6574b6ede83dd48a4fbc0e70b8d8. It is advisable to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2025-15632?

How do I fix CVE-2025-15632?

No fix has been published for CVE-2025-15632 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-15632 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15632 exists.

Sources

Also known as GHSA-jx24-j485-cqwm.

Is CVE-2025-15632 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free