{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15632 exists.","fix":"No fix has been published for CVE-2025-15632 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-15632 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-15632 and fix it if it is affected.\n\nWhat it is: CVE-2025-15632 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-15632 exists.\n\nAffected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-15632/ (Markdown: https://insights.sbomify.com/CVE-2025-15632/index.md)","id":"CVE-2025-15632","markdown":"https://insights.sbomify.com/CVE-2025-15632/index.md","name":"CVE-2025-15632","record":{"aliases":["GHSA-jx24-j485-cqwm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"MaxKB web application","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts in user browsers via a cross-site scripting flaw in the MdPreview component of MaxKB.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in 1Panel-dev MaxKB up to 2.4.2. Impacted is an unknown function of the file ui/src/chat.ts of the component MdPreview. Such manipulation leads to cross site scripting. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.5.0 is recommended to address this issue. The name of the patch is 7230daa5ec3e6574b6ede83dd48a4fbc0e70b8d8. It is advisable to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"1Panel-dev MaxKB MdPreview chat.ts cross site scripting","id":"CVE-2025-15632","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":8,"next":{"headline":"HCL BigFix WebUI is affected by an improper authorization vulnerability","id":"CVE-2025-15633"},"packages":[],"prev":{"headline":"Weak Credential Storage in TP-Link Omada Devices","id":"CVE-2025-15631"},"products":["MaxKB"],"published":"2026-04-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-13","vendors":["1Panel-dev"]},"summary":"Remote attackers can execute arbitrary scripts in user browsers via a cross-site scripting flaw in the MdPreview component of MaxKB.","url":"https://insights.sbomify.com/CVE-2025-15632/"}